Processing Delays in Ordering Imagery
Incident Report for GBDX Platform
Resolved
This incident has been resolved.
Posted Mar 25, 2021 - 17:15 UTC
Identified
Our ordering processing infrastructure is running behind which is causing delays in the ordering and delivery of products.
Posted Mar 25, 2021 - 16:21 UTC
This incident affected: Ordering API.