Processing Delays in Ordering Imagery
Incident Report for GBDX Platform
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 23, 2019 - 01:28 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Aug 22, 2019 - 22:21 UTC
Identified
The order processing infrastructure is experiencing delays in the ordering and delivery of products. New order submissions are being queued.
Posted about 1 month ago. Aug 22, 2019 - 21:12 UTC
This incident affected: Ordering API.