Elevated RDA API Errors
Incident Report for DigitalGlobe Platform
Resolved
The underlying issue has been resolved. Systems are operational.
Posted 12 days ago. Aug 13, 2019 - 21:04 UTC
Investigating
We're experiencing an elevated level of RDA API errors.
Posted 12 days ago. Aug 13, 2019 - 20:59 UTC